Trasteando con Sistemas

Actualizar versión bases de datos mysql 5.5w

Por 26/03/2016 enero 16th, 2017 Aún sin comentarios

En algunas ocasiones, puede que necesitemos actualizar nuestras bases de datos, por ejemplo, en una migración de servidor, cuando migramos de un servidor con una versión mysql superior a una inferior y tratamos de importar la base de datos, nos puede dar errores, seguramente si esta estuviese codificada como utf8_mb4 en mysql 5.5x y pasamos a una versión inferior, nos dará errores de codificación que podrán subsanarse con actualizar nuestra versión a una versión superior.

Actualización de mysql a 5.5w en centOS 6

Para listar las versiones de mysql:

#yum list installed | grep -i mysql<span id="mce_marker" data-mce-type="bookmark" data-mce-fragment="1">​</span>

 

Usando el repositorio yum de webtatic y un plugin para cambiar las librerías mysql antiguas por las nuevas:

#rpm -Uvh http://mirror.webtatic.com/yum/el6/latest.rpm
#yum install mysql yum-plugin-replace
#yum replace mysql --replace-with mysql55w

 

Reiniciando el servicio:

#service mysqld start

En plesk podría ser necesario reiniciar el servidor:

#reboot -h now

 

Anímate a comentar

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.